add_theme_support(‚widget-customizer’) Ci nie działa w WordPress 3.9 RC?

WordPress 3.9 zostanie najpewniej wydany w tym tygodniu więc testom kompatybilności nie ma końca. Tym razem dał o sobie znać problem z wyświetlaniem widżetów w widoku personalizacji motywu.

Pomimo dodania w motywie linijki:

add_theme_support('widget-customizer');

W widoku personalizacji motywu po panelach bocznych nie było nawet śladu. Po chwili odkryłem korelację pomiędzy ich pojawianiem się tam a dodawaniem jednego z widżetów na ekranie zarządzania widżetami. Okazuje się, że po prostu WordPress 3.9 RC zawiera błąd załatany wczoraj. Także jeżeli chcecie na spokojnie potestować sobie tą funkcjonalność to wystarczy podmienić sobie plik wp-includes/js/customize-preview-widgets.min.js na najnowszą wersję z repozytorium.

Problem występuje wtedy gdy motyw lub wtyczka tworzy panele boczne gdzie parametry before_widget, after_widget, before_title oraz after_title są puste – wtedy skrypt z wersji RC po prostu napotyka błąd i kończy działanie.